Back to overview
Downtime

Website unavailable

May 20 at 11:01pm CEST
Affected services
Website (vzug.com)

Resolved
May 21 at 06:30am CEST

We have identified the root cause and fixed it. All services are back online and functional as usual.

Created
May 20 at 11:01pm CEST

The website (including B2B shop) is currently not available because of an ongoing server issue. We are working on a solution to fix this as soon as possible.